Before reporting bugs, bear in mind that two out of three times the following are the four most common causes for failure in order of frequency:
  • no matter how reputable your (many) sources are or how your issues are seemingly unrelated (from missing soundtracks to choppy sound), you may well be using a bad dump and the best way to avoid it, is to rip your copy from your own disc and confront its hash to the ones at redump.org;
  • your specific game may give unexpected results due to a HLE BIOS bug, try using a BIOS file (preferably SCPH-7502, other versions may not work properly);
  • many games released from 1998 onward are copy-protected, use the corresponding SBI file from redump.org for image files or enable subchannel reading for real discs;
  • you are using an old version of the emulator, in which case you'd better try using the latest development revision for your operating system.

A reputable database for auditing image files using hashes is http://redump.org. From the same website you can download SBI files to bypass copy protection.

The following is an incomplete compatibility list of games that need a BIOS file to run without issues:
PCSX-Reloaded incomplete HLE compatibility list

Unofficial PPA with development versions for Ubuntu-based systems: http://launchpad.net/~rebuntu16/+archive/pcsx-reloaded-svn+unofficial
Unofficial SVN builds with development versions for Microsoft Windows: http://www.emucr.com/search/label/PCSX-Reloaded
Unofficial SVN builds with development versions for Mac OS X: http://consoleemu.com/emulator/pcsx-reloaded.



Quick compilation & installation guide from Subversion for Trisquel 6.0 LTS and Ubuntu 12.04 LTS:

sudo apt-get install subversion autoconf intltool libtool libsdl1.2-dev libgtk-3-dev libxv-dev libxtst-dev nasm
svn co https://pcsxr.svn.codeplex.com/svn/pcsxr pcsxr
cd pcsxr/
./autogen.sh
./configure
make
sudo make install

For OpenGL support: install libxxf86vm-dev and add option --enable-opengl to ./configure.

To build on Mac OS X, you will need Mac OS X 10.9 or later, with Xcode 6.1 or later. You will also need a version of the SDL2 framework installed in /Library/Frameworks/. Double-click Pcsxr.xcodeproj or Pcsxr.xcworkspace in the macosx subfolder, select Archive from the Project menu. After the build is finished, the Organizer window will pop up. Click the export button, then select either "signed Application" or just application.

Last edited Feb 8, 2015 at 12:57 PM by MaddTheSane, version 36

Comments

emvivre Sep 4 at 11:13 AM 
The svn is not longer used in this project. To fetch the code source git is required :
$ git clone https://git01.codeplex.com/pcsxr

Please update the documentation accordingly.

michellefland Apr 4 at 9:02 PM 
please create new stable version for windows very long time

michellefland Nov 24, 2015 at 9:13 AM 
not work pcsxr with windows 10 help my please thanks

wingnux Dec 12, 2012 at 4:44 AM 
libgtk-3-dev is now needed for ubuntu/debian compilation.

inukaze Oct 23, 2011 at 10:16 AM 
For Debian Squeeze Stable :


sudo apt-get install gawk mawk gcc gcc-multilib intltool intltool-debian gettext gettext-base liblocale-gettext-perl libgettext-ruby1.8 perl perl-base perl-modules libperl5.10 pkg-config libxml2 libxml2-dev libxml2-utils python-libxml2 libgtk2.0-0 libgtk2.0-bin libgtk2.0-common python-gtk2 libgtk2.0-dev libglade2-0 libglade2-dev python-glade2 libsdl-sge-dev libsdl-perl libsdl-ruby libsdl-ruby1.8 libsdl-gfx1.2-dev libsdl-ttf2.0-dev libsdl-console-dev libsdl1.2-dev libsdl-image1.2-dev libsdl-mixer1.2-dev libsdl-net1.2-dev libsdl-sound1.2-dev gstreamer0.10-sdl libsdl-ocaml-dev libsdl-pango-dev libguichan-sdl-0.8.1-1 zlib-bin zlib1g zlib1g-dev libxvmc1 libxv-dev libxv1 libxcb-xv0 libxcb-xtest0 subversion libtool nasm libbz2-dev automake autoconf libxxf86vm-dev x11proto-record-dev libxtst-dev libgmp3-dev libcdio-dev libsndfile1-dev && sudo apt-get update && sudo apt-get upgrade

reset && cd $HOME
mkdir svn && cd svn
svn co https://pcsxr.svn.codeplex.com/svn pcsxr && cd pcsxr/pcsxr/
autoreconf -f -i && ./configure --enable-opengl && make && sudo make install && sudo ldconfig && reset
pcsxr

inukaze Sep 3, 2011 at 5:58 PM 
For Debians / Ubunters and Derivate , you can use the follow line to install all deps , and not have errors :

sudo apt-get install gawk mawk gcc gcc-multilib gcc-4.5 gcc-4.5-base gcc-4.5-locales gcc-4.5-multilib gcc-4.5-plugin-dev intltool intltool-debian gettext gettext-base liblocale-gettext-perl libgettext-ruby1.8 perl perl-base perl-modules libperl5.10 pkg-config libxml2 libxml2-dev libxml2-utils python-libxml2 libglib2.0-0 libglib2.0-bin libglib2.0-data libglib2.0-dev libgtk2.0-0 libgtk2.0-bin libgtk2.0-common python-gtk2 libgtk2.0-dev libglade2-0 libglade2-dev python-glade2 libsdl-sge-dev libsdl-perl libsdl-ruby libsdl-ruby1.8 libsdl-gfx1.2-dev libsdl-ttf2.0-dev libsdl-console-dev libsdl1.2-dev libsdl-image1.2-dev libsdl-mixer1.2-dev libsdl-net1.2-dev libsdl-sound1.2-dev gstreamer0.10-sdl libsdl-ocaml-dev libsdl-pango-dev libguichan-sdl-0.8.1-1 zlib-bin zlib1g zlib1g-dev libxvmc1 libxv-dev libxv1 libxcb-xv0 libxcb-xtest0 subversion libtool nasm libbz2-dev automake autoconf libxxf86vm-dev x11proto-record-dev libxtst-dev libgmp3-dev libcdio-dev libsndfile1-dev


reset && cd $HOME
mkdir svn && cd svn
svn co https://pcsxr.svn.codeplex.com/svn pcsxr && cd pcsxr/pcsxr/
autoreconf -f -i && ./configure --enable-opengl && make && sudo make install && sudo ldconfig && reset
pcsxr