This project is read-only.

Errors in Games??

Jun 9, 2009 at 9:40 PM

I don't know if this is the place to put this discussion.  I have tried to play Final Fantasy 7 maybe four or five times with this emulator everytime I get off of the train and into the first battle the emulator crashes.

Jun 10, 2009 at 6:39 AM
Edited Jun 10, 2009 at 7:36 AM

using a real BIOS instead of the internal HLE bios may fix the problem. The Internal HLE bios is still incompleted and incompatible with many games.

Jun 10, 2009 at 9:36 PM

I a using SCPH1001.bin and it still happens.  Also something else you might need to know is that I am running this emulator on Ubuntu Jaunty Jackalope 64 bit.

Jun 11, 2009 at 2:49 AM

well it didn't happen on my Debian Lenny i386 and Fedora 11 x86_64. Is scph1001.bin already selected in the configuration dialog box?

Jun 12, 2009 at 11:43 PM
Edited Jun 12, 2009 at 11:45 PM

I just did a reinstall of Ubuntu and now I do not have this problem.  That is pretty weird.  Well anyways another problem I have when playing this game is with the sound.  I don't think that this emulator is picking up my sound card.  The old PCSX had some plugins that enabled sound on my computer.  Would it be possible for me to use some of the plugins designed for that emulator on PCSX-Reloaded?  Also what directory would I move them to?


Oh and by the way I think that PCSX-Reloaded is an awesome emulator.  I love the direction it is taking.

Jun 13, 2009 at 3:19 AM
Edited Jun 13, 2009 at 4:59 AM

it is possible to use other plugins on 32-bit x86, but not on x64 (especially with the plugins whose source code is not available, such as spuEternal). the plugins should be copied to ~/.pcsx/plugins

try the command "padsp pcsx" if you are using a pulseaudio-based distro.

Jul 22, 2009 at 7:43 PM

I was wondering if their is a compatibility list that I can check to see if my games work.

Jul 24, 2009 at 2:20 PM
Edited Jul 24, 2009 at 2:54 PM

maybe check out the pcsxbox compatibility list, most of this also applies to pcsxr (with a few exceptions, like "Rhapsody - A Musical Adventure"):

Jul 26, 2009 at 3:07 AM

Heya guys,

Just got the latest alpha release and was very pleased at what I've seen so far - was considering moving from epsxe to this emulator... If it weren't for this Final Fantasy 8 and 9 bug - which is why I'm posting this here.

FF7 works fine.

I enabled console output in the CPU options, and it seems FF8 stops working at this point:

[code]* Configuration : EvCB 0x16            TCB     0x04                                                 
 * boot file     : cdrom:\SLES_020.80;1                                                              
 * EXEC:PC0(80011860)  T_ADDR(80010000)  T_SIZE(00190800)                                            
 * boot address  : 80011860 80200000                                                                 
 * Execute !                                                                                         
 *                 S_ADDR(80200000)  S_SIZE()                                                        
 * Change effective memory : 2 MBytes                                                                
 * ResetGraph:jtb=8005ee54,env=8005ee9c                                                              
 * CD_init:addr=8005ddf8[/code]

And FF9 stops when it get's here:

[code]* Configuration : EvCB 0x16            TCB     0x04
 * boot file     : cdrom:\SLES_029.65;1
 * EXEC:PC0(80012b5c)  T_ADDR(80010000)  T_SIZE(001de000)
 * boot address  : 80012b5c 801fff00
 * Execute !
 *                 S_ADDR(801fff00)  S_SIZE()
 * ResetGraph:jtb=80066c30,env=80066c78
 * CD_init:addr=80068b4c
 * CD_init:addr=80068b4c[/code]


Now for the other useful info:
I'm using Fedora 10, x86 version (upgrading to F11 when I get some new disks)
I've used the pre-compiled rpm from your website (cheers!)
It works with a few other game ISO's.
I'm loading it from ISO's *AND* discs (I want to use ISO's to stop the noise/scratching of the discs) - so it's definitely not an invalid image.
I've changed through various GPU settings and all CPU/disc settings I can find in the GUI
I've changed the BIOS (internal->1001->7502).. None of the 3 work.

To possibly help matters more, when I select "show FPS" in the GPU options, it isn't even showing up on FF8/9.. So possibly the graphical part isn't even being initialized?

I was going to try and strace the process, and install an earlier version (as I guess it could be the "alpha" status that has caused this.


Any suggestions?
Only thing I can think of is it's the core emulation code while it's running the very start of the disc.. But I kick myself for thinking that since I don't know enough.

In the meantime I guess I'm stuck with epsxe - but thanks all the same guys - I will watch this project very closely!


Jul 26, 2009 at 9:56 AM
Edited Jul 27, 2009 at 6:12 AM

the PAL versions of FF8 need to be patched as they are copy-protected and there are currently some issues with emulating the protection in the emulator.

The patches can be downloaded at: (download the "Protection Fix" patch corresponding to your language)

there is also a FF9 patch, however it doesn't seem to work.

the NTSC version doesn't have the problem.


EDIT: that FF9 UK patch works with OpenGL plugin but not software or XVideo plugin.

Jul 27, 2009 at 1:05 PM


Jul 27, 2009 at 11:50 PM

Right, sorry about that earlier post. My phone really doesn't like me right now.

I've applied the PPF to FF8, and it has worked.. I still get a weird glitch right at the start, and I'll see if I run into anything in the game itself, and it's comparison to epsxe.

So far, I've run into a joypad problem which I'll add to another topic.

Thanks for posting the link to the PPF's.

Is it possible for you to also show the link to the "applyppf" binaries, since it was a small job to find them (although it turns out they're on the same website as linked under a different page).