Compilation problem - 1.9.93

May 21, 2014 at 9:52 PM
Edited May 22, 2014 at 2:21 AM
I apologise if this is a banal issue, but I've tried to look around for a resolution, and found nothing useful. I can't get past ./configure:
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for ANSI C header files... yes
checking dependency style of gcc... gcc3
checking for ranlib... ranlib
./configure: line 4664: syntax error near unexpected token `2.2.6'
./configure: line 4664: `LT_PREREQ(2.2.6)'
Here's config.log: http://pastebin.com/yP7WiqDQ

autogen.sh prints out a whole lot of errors by the way:
$ ./autogen.sh
Rebuilding ./configure with autoreconf...
libpcsxcore/Makefile.am:6: warning: source file '$(top_builddir)/libpcsxcore/psxbios.c' is in a subdirectory,
libpcsxcore/Makefile.am:6: but option 'subdir-objects' is disabled
automake: warning: possible forward-incompatibility.
automake: At least a source file is in a subdirectory, but the 'subdir-objects'
automake: automake option hasn't been enabled.  For now, the corresponding output
automake: object file(s) will be placed in the top-level directory.  However,
automake: this behaviour will change in future Automake versions: they will
automake: unconditionally cause object files to be placed in the same subdirectory
automake: of the corresponding sources.
automake: You are advised to start using 'subdir-objects' option throughout your
automake: project, to avoid future incompatibilities.
libpcsxcore/Makefile.am:6: warning: source file '$(top_builddir)/libpcsxcore/cdrom.c' is in a subdirectory,
libpcsxcore/Makefile.am:6: but option 'subdir-objects' is disabled
libpcsxcore/Makefile.am:6: warning: source file '$(top_builddir)/libpcsxcore/psxcounters.c' is in a subdirectory,
libpcsxcore/Makefile.am:6: but option 'subdir-objects' is disabled
libpcsxcore/Makefile.am:6: warning: source file '$(top_builddir)/libpcsxcore/psxdma.c' is in a subdirectory,
libpcsxcore/Makefile.am:6: but option 'subdir-objects' is disabled

[...]

plugins/bladesio1/Makefile.am:4: error: Libtool library used but 'LIBTOOL' is undefined
plugins/bladesio1/Makefile.am:4:   The usual way to define 'LIBTOOL' is to add 'LT_INIT'
plugins/bladesio1/Makefile.am:4:   to 'configure.ac' and run 'aclocal' and 'autoconf' again.
plugins/bladesio1/Makefile.am:4:   If 'LT_INIT' is in 'configure.ac', make sure
plugins/bladesio1/Makefile.am:4:   its definition is in aclocal's search path.
LT_INIT is present under configure.ac as "LT_INIT([disable-static])"
May 23, 2014 at 5:23 PM
Nevermind, I was missing libtool and libltdl-dev, I ran automake.sh again and it works now (although automake still gives me a lot of errors)