Muting PCSX-R in Linux

Nov 9, 2011 at 10:32 PM

I would like to be able to mute PCSX, and listen to my music while I play, however the closest thing I see is a Volume:Low setting in the options menu. Is there something I am missing, or is it impossible to mute?

Nov 10, 2011 at 6:25 PM

This is PCSX-r, not original PCSX.

In options of sound plugin set "volume - none".

I'm using svn version with openal sound plugin backend.

Nov 10, 2011 at 8:50 PM

My mistake in the post, I am using PCSX-r

I don't see that option. In fact, I don't even see a sound plugin option. The closest I can see is  "Disable CD Audio" in Configure CPU (which isnt working) And the volume settings I mentioned earlier in configure sound.

I installed the "pcsxr_1.9.92-1_i386.deb" or "pcsxr_1.9.92-1_amd64.deb" from the downloads section, I can't remember which. Is the version you use different, which enables you to set the sound plugin?

Nov 11, 2011 at 10:12 AM
Edited Nov 11, 2011 at 10:23 AM

I'm sorry, I was wrong. I meant the "Configure sound"

http://i44.tinypic.com/ndpm3q.jpg

I use the development version

http://pcsxr.codeplex.com/SourceControl/list/changesets

But you need to compile it to use

http://pcsxr.codeplex.com/documentation

To choose openal sound backend install libopenal-dev and add --enable-sound=openal to ./configure

Nov 11, 2011 at 6:33 PM

Ok, I still can't get this to work, tried two methods here which I will outline below, hopefully you can tell where I fucked up. After installing libopenal-dev...

First method: straight off http://pcsxr.codeplex.com/documentation, the one that said For Debians / Ubunters and Derivate

The only difference is I changed the install line to what I thought you were telling me t do : "autoreconf -f -i && ./configure --enable-sound=openal --enable-opengl && make && sudo make install && sudo ldconfig && reset"

The second method I installed the "Latest Version" off of  http://pcsxr.codeplex.com/SourceControl/list/changesets, and ran the same install line as above.

Either way, when running pcsx-r the first time I got this message :

"Configuration file /home/bill/.pcsxr/pcsxr.cfg couldn't be found

Picking default plugin: libGXVideo.so

Picking default plugin: libDFSound.so

Picking default plugin: libDFCdrom.so

Picking default plugin: libDFInput.so

Picking default plugin: libDFInput.so

Picking default plugin: HLE

Error - no configuration file"

And it would seem that the sound settings are the same as they were previously, with no mute option.

Can you see what I am doing wrong?

 

Thanks a ton for your patience and help.

Nov 18, 2011 at 1:19 AM

Ahahahaha. I did a little more digging and I found a easy way to mute applications in Mint. (At least under Mint) Preferences-> Sound Preferences -> Applications.

Thanks for all the helpful replies.