[Mac] Unable to Build new versions

Mar 3, 2011 at 6:10 AM

I can't seem to build the latest version, it's giving me an error that "GCC 4.2 is not compatible with the Mac OS X 10.4 SDK (file drawgl.m)" however I can't seem to fix this by changing the compiler to GCC 4.0 - it still gives the same error if I select GCC4.0. Am I selecting it in the wrong place? I'm using Get Info and the "Build" tab within.

Apr 5, 2011 at 5:00 PM

after  I update the Xcode project (and all subprojects) to use 10.6 sdk/GCC 4.2, I get the following error in texture.c and menu.c while compiling PeopsXGL: "error: 'glColorTableEXT' undeclared (first use in this function)"

i googled around and found a hack here: http://www.garagegames.com/community/forums/viewthread/115277/1

it appears that glColorTableEXT is deprecated in 10.6sdk.

adding the following to externals.h fixed the compile-time errors:

 

#ifndef GL_COLOR_INDEX8_EXT

#define GL_COLOR_INDEX8_EXT 0x80E5

#endif

#ifndef glColorTableEXT

#define glColorTableEXT glColorTable

#endif

 

 

i haven't checked if it works properly though

 I don't know if it's the proper place to put the code in.

If possible update the sources as you see fit, please.

Thank you