pcsx(-r) problems on mac

Jan 1, 2010 at 10:26 PM

Hello there!

 

I'm afraid this is gonna be a big one, at least it feels like it ...

 

First of all, I was very happy to get a hold on a mac version of pcsx-reloaded and pcsx. First I tried pcsx and encountered two problems.

1. I got the playstation bios and copied it to Library/Application Support/Pcsx/Bios/. But when starting the program there's still the "missing bios"-warning appearing.

2. I mount a disc via Toast Titanium, run it in pcsx and get supposedly the black pcsx load screen or something like that? However, it crashes after one to five seconds.

 

With pcsx-reloaded there are quite the same problems.

1. the missing bios warning also appears.

2. Instead of a plain crash, it says that it could not read the cd-rom.

 

I'd appreciate if someone could share his or her experiences and maybe offer a solution to this?

I'm using a MacBook with Snow Leopard, 2GHz Intel Core 2 Duo.

Thanks a lot.

Coordinator
Jan 3, 2010 at 5:02 AM

make sure your BIOS file is valid, i.e., size is 524,288 bytes.

also you could use "Run ISO" in the menu

Jan 3, 2010 at 8:50 AM

I checked the BIOS, it seems to be quite valid. Has correct size after all. (I'm using the 1001)

And I also tried running ISO, and it still says "could not read CD-ROM". I'm quite helpless right now .. :(

Jan 20, 2010 at 11:45 AM

I don't know how familiar you are with your mac, but did you by chance copy it to the wrong library? there is a library folder for every user including the root user. I had the identical issue until I checked and realized I copied it to /library/application support/pcsx/bios instead of /users/myname/library/application support/pcsx/bios. Sorry if that's an overly-obvious tip. Seriously, the redundacy of unix on a single user desktop.

Jan 29, 2010 at 10:57 AM

Hey guys! I'm having the exact same problem as frostmuh. Configured the BIOS perfectly (Works in PCSX 1.6) but for some reason I keep on getting the "Could not check/read/verify" CD-Rom message :S. Same happens with any ISO's I try. I'm running Snow Leopard on a 13 inch Macbook Pro. Thanks for the help!

Jan 30, 2010 at 6:19 PM

I just wanted to say I'm not experiencing this and I have a 17" Macbook Pro with 10.6.2. I'm not actually trying to read a disk though I'm just using load ISO and I've only tried with ff9 so..maybe it's game specific or something. 

Feb 6, 2010 at 2:59 PM

Just a quick update, still having the same problem with any disk I try. Tried compiling from the latest source code using Xcode, but I'm STILL having the same problem. Any help would be much appreciated. Thanks!

Feb 6, 2010 at 11:40 PM
Edited Feb 6, 2010 at 11:41 PM

edit: Opps, meant to reply on another thread... sorry.