Problems building in PowerPC

Nov 28, 2009 at 2:34 PM

I tried to compile under xubuntu 9.10 ppc but it does nothing. The system is a new install with these packages added:

x11proto-bigreqs-dev x11proto-composite-dev x11proto-core-dev x11proto-damage-dev x11proto-dmx-dev x11proto-evie-dev x11proto-fixes-dev x11proto-fontcache-dev x11proto-fonts-dev x11proto-gl-dev x11proto-input-dev x11proto-kb-dev x11proto-print-dev x11proto-randr-dev x11proto-record-dev x11proto-render-dev x11proto-resource-dev x11proto-scrnsaver-dev x11proto-trap-dev x11proto-video-dev x11proto-xcmisc-dev x11proto-xext-dev x11proto-xf86bigfont-dev x11proto-xf86dga-dev x11proto-xf86dri-dev x11proto-xf86misc-dev x11proto-xf86vidmode-dev x11proto-xinerama-dev xcb-proto intltool libperl-dev libtoolkit-perl cproto pkg-config desktop-file-utils libvorbis-dev libglib2.0-0 libglade2-0 libglade2-dev libgladeui-1-dev libxv-dev libclalsadrv-dev libgd2-noxpm libbogl0 libbogl-dev libusplash-dev fakeroot dpkg-dev g++ gpp libsdl-dev libcdio-dev libsndfile1-dev libsdl-net1.2-dev python-tk xnest

The last lines that it shows after trying to compile are:

/bin/bash ../../libtool --tag=CC   --mode=link gcc  -g -O2 -fno-dse   -o cfgDFCdrom cfg-gtk2.o main.o support.o interface.o callbacks.o -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lpangoft2-1.0 -lgdk_pixbuf-2.0 -lm -lpangocairo-1.0 -lgio-2.0 -lcairo -lpango-1.0 -lfreetype -lfontconfig -lgobject-2.0 -lgmodule-2.0 -lglib-2.0   
libtool: link: gcc -g -O2 -fno-dse -o cfgDFCdrom cfg-gtk2.o main.o support.o interface.o callbacks.o  /usr/lib/libgtk-x11-2.0.so /usr/lib/libgdk-x11-2.0.so /usr/lib/libatk-1.0.so /usr/lib/libpangoft2-1.0.so /usr/lib/libgdk_pixbuf-2.0.so -lm /usr/lib/libpangocairo-1.0.so /usr/lib/libgio-2.0.so /usr/lib/libcairo.so /usr/lib/libpango-1.0.so /usr/lib/libfreetype.so -lz -lfontconfig /usr/lib/libgobject-2.0.so /usr/lib/libgmodule-2.0.so /usr/lib/libglib-2.0.so
make[1]: Leaving directory `/home/user/Desktop/pcsxr/plugins/dfcdrom'
make[1]: Entering directory `/home/user/Desktop/pcsxr'
make[1]: Nothing to be done for `all-am'.
make[1]: Leaving directory `/home/user/Desktop/pcsxr'

Could anyone help me?

Coordinator
Nov 28, 2009 at 3:43 PM

run "make install" to install the program after compilation.

note that I don't have a PowerPC box so I don't guarantee the program still works on PowerPC.

Nov 28, 2009 at 7:04 PM

Thanks.
It worked, but it didn't make the OpenGL plugin and I need that one, coz the XVideo Driver gives the RGB error and I know that the other will work (in other machine, in VirtualBox, the x86 version gives the same error but the OpenGL works perfect).
Is there a way to compile only that plugin?

 

Coordinator
Nov 29, 2009 at 5:27 AM
Edited Nov 29, 2009 at 5:29 AM

the opengl plugin doesn't support Big-Endian yet so don't bother.

which video-card and driver are you using?

Nov 29, 2009 at 9:25 AM

I manage to compile the dfOpenGL plugin but it gives a segmentation fault. The system was a PS3, I guess there is no way to make pcsxr to work on it. Thanks anyway.