This project is read-only.

Joypad not quite joy-ful.

Jul 28, 2009 at 12:02 AM

Heya guys.

I've got a nifty USB tool which links up my PSX joypad to my USB port.
I hook it up, the linux kernel spots it in dmesg, I can use it in KDE (window manager) for hotkeys etc.
It hooks up a udev device being: /dev/input/js0... As per the norm.

I got it working in epsxe using the plugin "ammoQ's padjoy joy" plugin - it's worked quite well (ie, no real problems).

I decided to use the built-in joypad plugin to pcsxr, the configuration window looks almost identical - so I'm guessing a fair bit of code is too.

Anyway, go through all the buttons setting them up, leave it on multithreaded, leave analogue off.. BOOM - not working.
The config window sees the input - but the emulator doesn't (in game using all BIOS's I can pick... and in just the BIOS's that I have).

Now, I flick between some options in CPU. If I deactivate "SIO IRQ" then the pointer appears in the BIOS screen - if I turn it on then the pointer doesn't appear and it often freezes.

I do the same with the analogue tick box in the joypad options - again, on=no pointer.

So I decide to copy the joypad plugin from epsxe - it has a pcsx emulation option!!

.. I enable it for joypad 1 (forgetting to switch the joypad 2 option over).. It still doesn't work...

.. BUT, switch both over, and it works... HURRAH!!

So, while I have a fully working joypad using a different plugin - I still wanted to let you guys know of these problems.
If you want me to try help out even more, I can try.
If anyone wants to hand me a "debug" pre-compiled RPM then I can always have a shot at that.


Jul 28, 2009 at 11:07 AM
Edited Jul 28, 2009 at 11:11 AM

not sure about this one as I don't have a joystick or adapter to test the plugin :( maybe someone else can fix it.

that plugin is basically identical to PCSX-df 1.9 (except the default keys and some minor fixes to the config utility), which is indeed based on the ammoQ padJoy plugin.

Aug 29, 2009 at 8:39 AM

I just bought a USB joystick and I'm unable to reproduce this, even mixing keyboard and joystick keys in the settings still works very well.

However if someone else also encountered the problem please let me know.

Sep 5, 2009 at 4:29 PM

I can confirm this. I have SPEEDLINK PS2 Dualshock Adapter. The problem is it doesn't work in every game - in works in Vagrant Story, but it doesn't budge at all in Final Fantasy Tactics.