DFInput error: could not open device /dev/input/js0!

Jun 21, 2009 at 2:48 AM
Edited Jun 21, 2009 at 5:16 AM

Hi

I downloaded pcsx and installed it on Fedora 11 32bits

when I try run a iso it works but in the presentation screen of the game it freeze.

I think this is because I must to press the start button on the controller, I try it but nothing occurs

So, I ran pcsx from the terminal and sends me the following issue:

[zuargo@zuargo-fedora ~]$ pcsx
Sound device not available!
RGB mode found. id: 3, depth: 24
DFInput error: could not open device /dev/input/js0!
DFInput error: could not open device /dev/input/js1!

But in the emulator, I can to configure the controller 1 (configuration > Plugins & BIOS > Controller 1) and recognizes it.

Now I will try run another iso... and I will see what happens

Please help me

thanks a lot

and sorry for my english I speak spanish

Coordinator
Jun 21, 2009 at 4:04 AM
Edited Jun 21, 2009 at 4:05 AM

if you would like to use joysticks, try running this as root:

chmod 666 /dev/input/js0

chmod 666 /dev/input/js1

if you are using keyboards you can just ignore the messages.

btw, please don't post link to ISO or other copyrighted material here! Next time I'll just delete the post as I'm not able to edit others' posts at this site.

Jun 21, 2009 at 5:28 AM

Sorry I edited my first post...

I tried with another iso and sends me the same issue but I could play, the keyboard works (I don't use joystick)

apparently the emulator doesn't works fine whit the first iso that I used or the iso is bad

thanks a lot for your answer and sorry again :)