Crackling audio with ALSA Sound

Dec 19, 2014 at 3:36 AM
Edited Dec 19, 2014 at 3:37 AM
I keep hearing crackles in every game I try with the above mentioned plugin. Emulation runs smoothly and there don't seem to be any issues with the gfx side of things, also the CPU usage never jumps over 40% so I doubt that it's a slow PC problem.
I've also tried out P.E.Op.S' OSS plugin, but I can't hear anything, and I also can't access the configure window.
Developer
Dec 19, 2014 at 5:18 PM
Edited Dec 19, 2014 at 5:25 PM
Hello Andoru,

What version of pcsxr are you using? If you are on a 64bit system P.E.Op.S OSS plugin will not work it's only a 32bit plugin.
If your on a 32bit system you can install the oss driver or you can try using the alsa-oss compatibility layer by typing

aoss pcsxr

in a terminal that will get the sound to work will P.E.Op.S OSS plugin. For the configure window to show up you will need some libraries. Look this site for how to do that.

How to get the gui configure window for P.E.Op.S OSS to work
Jan 7, 2015 at 4:54 PM
Thanks for the answers, got the OSS plugin working, but it stutters at times for some reason.
Any idea why the ALSA Sound plugin isn't working properly?
Developer
Jan 7, 2015 at 7:37 PM
Edited Jan 7, 2015 at 7:37 PM
Hello Andoru,

It might be the settings in sound plugin i would suggest you try these settings.


**Volume = Low
**Reverb = Off
**Interpolation = None
**Adjust XA Speed = Off
**High Compatibility mode = Off
**SPU IRQ Wait = Off
**Single Channel Sound = Off
**Frequency Response Output Filter = Off

Could also be your running a very old version of pcsxr.
Jan 10, 2015 at 3:06 AM
Just a guess, have you used a manual FPS settings at 60fps or 50fps depending on game?

I've found no matter what settings I choose I'll always get crackling with the Autodetect because it runs at 49 and 59 fps.

The crackling goes away if I set it manually to 60 or 50, which is extremly anoying because I have to change it per game.
Jan 10, 2015 at 3:57 AM
Edited Jan 10, 2015 at 3:58 AM
Solis wrote:
It might be the settings in sound plugin i would suggest you try these settings.
I've been able to isolate High Compatibility mode as the one that causes the choppy/crackling audio. It's quite weird since I'd expect that to not take that much CPU when emulating. Even when ignoring that, why does this happen even though the CPU usage barely goes over 30% per core (dualcore here)?

Solis wrote:
Could also be your running a very old version of pcsxr.
Sorry for not mentioning earlier, I'm currently running v1.9.93 compiled by myself, which from what I can see is the latest version.

AzaIndustries wrote:
Just a guess, have you used a manual FPS settings at 60fps or 50fps depending on game?
That didn't seem to change much, I was still getting a fluctuating FPS rate from 58 to 60 (in NTSC games ofcourse)
Jan 10, 2015 at 7:09 AM
Edited Jan 10, 2015 at 7:10 AM
Bugger, Though I'm curious why your FPS would fluctuate at all.
In my experience if you have enough performance it should run at a solid 60fps.

And I know that any time I've ever had a lower then perfect FPS in most emulators (dolphin/pcsxr/pcsx2/mame) that the audio suffers from it.

That being said, I did have early audio issues with crackling in PCSXR, I'll try and remember how I fixed them and post back here.
Developer
Jan 10, 2015 at 3:00 PM
Edited Jan 10, 2015 at 3:28 PM
Hello Andoru,

Pcsxr-1.9.93 came out in aug 13 2013 it's pretty old now. The lastest version of pcsxr is pcsxr-92300. You can find it here.

PCSXR-Latest

BTW: If you plan on just using the HLE-bios you might want to add some changes to get more games memory card
working you have a look at the page below.

Pcsxr-HLE-Bios Compatibility List
Jan 10, 2015 at 11:58 PM
Okay, compiled the (real) latest version and didn't change much. I do get a constant 60fps in games (NTSC) with the OpenGL and XVideo drivers, but not with PEOpS softX driver for some reason, it still fluctuates like crazy with that plugin. Unfortunately I still have crackling with High Compatibility mode enabled.
Developer
Jan 11, 2015 at 1:57 PM
Hello Andoru,

Since your using the 32bt version of pcsxr you can use eternal spu.

Eternal Spu 1.4.1 Linux

You will this package as well

libstdc++2.10