Can't install Pete's XGL2 on PCSX-R 1.9.92 using Ubuntu 14.04

Nov 9, 2014 at 3:16 PM
So what I do is the following:

copy gpuPeteXGL2.cfg to ~/.pcsx/plugins/

copy and cfgPeteXGL2 to /usr/lib/x86_64-linux-gnu/psemu/

I noted that the cfgPeteXGL2 is an executable file, while the other files used by the emulator are shared library files.

When I run PCSX-R, it automatically generates links to cfgPeteXGL2 both in ~/.pcsx/plugins/ and in ~/.pcsx/plugins/cfg/, but it does not generate a link to ""

And consequently Pete's XGL2 does not appear in the video plugin list.

Is there any way of fixing this? Am I doing something wrong?
Nov 9, 2014 at 7:20 PM
Hello Sanwablo,

32bit plugins don't work with 64bit systems.
Nov 9, 2014 at 7:42 PM
Hi Solis, thanks for your reply.

You're right, I'm using a 64bit distro. Is that plugin only available for 32bit? Is there any other you could recommend in this case?
Nov 9, 2014 at 8:07 PM
Yeah, sorry, it's 32 bit only, and the plugin is closed source.
You could try the GL plugin that comes with PCSXR (I'm not sure if your distro packages it already)
Nov 21, 2014 at 9:22 AM
Edited Nov 21, 2014 at 9:22 AM
Thanks uyjulian.

Yes, the OpenGL plugin comes with the emulator, and overall it works quite well actually.

It's a shame people make closed source plugins for emulators! It doesn't make much sense to me.
Nov 21, 2014 at 9:34 AM
Actually, Pete's OpenGL 2 plugin has not been updated in a while.