Gameshark Support

Feb 28, 2013 at 6:21 PM
I've been searching EVERYWHERE for a Gameshark support for PCSX-R (Mac version if necessary) and haven't found one. Has anyone found one? If so please link it to me!
Cheers, TheTrueTurtle.
Mar 1, 2013 at 10:43 AM
Heyya!

On Windows at least, you can download and install PEC (PSX Emulation Cheater). This is a video plugin replacement that injects Gameshark codes into the running game. Within this, you can set your preferred video plugin to use, so no change there.

Grab PEC here: http://pec.duttke.de/download.php

Remember to set the plugin to "psx emulation cheater" and configure it too, to set your real video plugin. (Pete's OpenGL2 plugin perhaps?:)

I can't help you with *NIX though...
Mar 1, 2013 at 11:24 AM
Nix? What's that? Anyway, I have Mac so I can't use PEC.
Thanks.
Mar 30, 2013 at 1:39 AM
Edited Mar 30, 2013 at 1:40 AM
I just got in contact with abergeron , here is how you load a cheat. Create a Mac document, the format is as follows:

[cheat name]
800XXXX XXXX
300XXXX XXXX
...

[other cheat]
800XXXX XXXX

save file, name it whatever .. I named mine xenogears, then load the game and use the cheats menu to open the cheats window and load from there. You can enable and disable the cheats with the checkboxes next to each cheat.

Enjoy!!
Mar 30, 2013 at 10:04 AM
I can't find a cheat menu on my PCSXR :/ Am I meant to? But thanks for the help, I appreciate it :)
Mar 31, 2013 at 3:37 AM
The "Cheats menu" that AnthonyR32 mentioned is an item in the File menu, but it is only present in the most recent Subversion builds starting earlier this month. It's not in the latest stable release, 1.9.92, which came out two and a half years ago.

The Subversion builds generally work pretty well and add several features not present in the last stable release, so it's a good idea to switch to them. As mentioned in the Documentation page here, you can download unofficial Subversion builds from http://consoleemu.com/emulator/pcsx-reloaded. For cheat support, you need 83315 or newer, but I suggest 83636 or newer, which fixes a crash in the SoftGL plugin.

When AnthonyR32 says "a Mac document", he means an ordinary plain text file, like you might make with TextEdit or something similar.

TheTrueTurtle wrote:
Nix? What's that? Anyway, I have Mac so I can't use PEC.
Thanks.
"*NIX", what Turion wrote in his last message, is a way of referring to general Unix-like systems such as Linux. There used to be many such systems around in the 1990s, and a lot of them had names ending in "-nix" or something like it. So some people would called them "*nix", where the "*" was meant to be a placeholder.

Many people consider the modern Mac OS to be a Unix-like system, since its underlying operating system uses a Unix interface.
Mar 31, 2013 at 8:37 AM
Edited Mar 31, 2013 at 8:51 AM
Ah, thank you! I still had the old version, I didn't know they updated, thanks!
Also, I still can't find the 'cheat' menu :/ is there something wrong?
Mar 31, 2013 at 8:56 AM
TheTrueTurtle wrote:
Ah, thank you! I still had the old version, I didn't know they updated, thanks!
Also, I still can't find the 'cheat' menu :/ is there something wrong?
Well, it's not actually a cheat menu, it's a Cheats command in the File menu, about in the middle of the menu just after Pause When Inactive.

If it's not there, be sure you're running the new version you downloaded, rather than the older version, and that the version you downloaded is one which is new enough to have the cheat support. That page I linked to with the unofficial Subversion builds lists them with the oldest at the top, so if you just grab the first build you see, you'll get one which isn't new enough. Better to grab the build at the end of the list, which is the latest. If for some reason that build doesn't work, move upward to earlier builds until you find one that does.
Mar 31, 2013 at 8:58 AM
Oh, haha. Didn't know that. I was about to ask about why my PCSXR keeps crashing as soon as I run a a game.Thanks.
Mar 31, 2013 at 9:03 AM
TheTrueTurtle wrote:
Oh, haha. Didn't know that. I was about to ask about why my PCSXR keeps crashing as soon as I run a a game.Thanks.
That's probably the crash in the SoftGL plugin I mentioned a couple posts back.

Like I said, that bug has apparently been fixed in the newest builds, but you can also use the OpenGL plugin instead, which shouldn't crash and probably runs faster anyway.
Mar 31, 2013 at 9:04 AM
I don't think there was an option for that, but do you have skype? It'd be a much faster way to communicate. Through Instant Messaging.
Mar 31, 2013 at 9:10 AM
TheTrueTurtle wrote:
I don't think there was an option for that, but do you have skype? It'd be a much faster way to communicate. Through Instant Messaging.
Sorry, I don't.

To switch the graphics plugin, you select Preferences... from the PCSXR menu to the left of the File menu. (You have to do this before running a game; the Preferences... command isn't available while a game is running.) You'll get a dialog box with various options. Click the Plugins button at the top of the box to choose and configure plugins.
Mar 31, 2013 at 9:11 AM
I know that, but I don't think there was an option in there for OpenGL Plugin. Thanks for helping :)
Apr 6, 2013 at 3:14 PM
Hello!

I couldn't find by myself how does that cheat option works and then i found this thread but i didn't get you explanation neither :p

What do you mean by create a "mac document" ? Is it a text edit file? And if it is, in which format should i save the file?

If someone could explain how does that works more precisely that would be really appreciated.

Cheerz!
Apr 6, 2013 at 3:15 PM
It's a textedit file, hope that helps. And save it in any format :D
Apr 6, 2013 at 3:27 PM
Thanks, that helped indeed. But now that i did that, i can effectively open the text file in the cheat menu but it doesn't show up in the bow.
I tried whit a loaded game as with no game loaded but it does the same thing. Any idea about that? :/
Apr 6, 2013 at 3:29 PM
Does it work in-game? That's all I could understand. If it doesn't, maybe you have a different version of the game that is incompatible with those codes?
Apr 6, 2013 at 3:40 PM
I don't think it's about the game version because i try to add cheats when there is no game loaded.

When i open the text file in the cheat menu, it just doesn't show up in the table.

So i don't get if it is hidden of if it just won't accept the text file.

Still, i'll try with an older subversion to see if it still does that
Apr 6, 2013 at 3:41 PM
Happened to me to just then, I just gave up on those gameshark codes :/ Hope you figure out soon! I couldn't do it.
Apr 6, 2013 at 3:57 PM
Edited Apr 6, 2013 at 4:37 PM
It seems that it does that on every version.

The only thing i noticed which seems to be buggy is that the table where the cheat list is supposed to be is surrounded by a blue high line that won't disappear no matter what i do. And i'm pretty sure it wasn't there at first.

Maybe the problem is that i don't write the codes in the good format and the cheat menu doesn't detect them properly.

If anyone could give an example of a working code list, that would be as useful as appreciated :)

P.S. : I tried to convert my code list into a PDF file and when i load it into the cheat menu, there's two line of cheat appearing with two box unchecked. Next to the first box it's wrote "/ICC Based 10 0 R" and next to the second it's a blank space.
Apr 6, 2013 at 6:02 PM
Guys, the cheat file has to be plain text. The Mac OS TextEdit program can save files in plain text or Rich Text format, and Rich Text is used by default (though this can be changed in TextEdit's Preferences).

To make a plain text file in TextEdit, you have to go into TextEdit's Format menu and select Make Plain Text.

PDF files won't work at all. PCSXR will try to interpret them as plain text, and the garbage you see is the result.
Apr 19, 2013 at 12:05 AM
Hello everyone!
i've got the same problem of kintokan, sadly...
Besides I tried to make text files just like colinh advises but without any result: the codes don't appear in the window!!! xD
May you help us? xD
Apr 25, 2013 at 9:25 AM
Hey guys, I sent a message to Blade_Arma, who is one of the programmers of the emulator. He told me that the file must NOT have a common text format, but a ".cht" file!!!
Nov 19, 2013 at 2:56 PM
Hey i know its been awhile since anyone posted on this topic but im having similar problems.

Im pretty knew to playstation emulators, but have got my pcsxr all set up and have downloaded final fantasy 7 disc one to play and want to use some cheat codes. Using cheats is the only reason i would play it on an emulator, i already have it on my ps3 and the original game itself for my ps2.

Anyway i followed all the advice on here, i downloaded the latest version of pcsxr, i created a ".cht" file with the gameshark codes i wanted to use, i think having written them all out correctly, then opened the cheat menu on pcsxr and tried to load the codes and nothing. I can select the file but when i press open nothing happens. The cheat menu/window stays blank.

This is really annoying me cause like i said its the only reason i want to play on an emulator for the cheats. Anyone resolved this yet? Hope to hear something soon.
Nov 20, 2013 at 8:20 AM
try my pec2pcsxr cheat converter...
(you have to rename the output for autoloading)