This project is read-only.

PCSX-R 1.9.92 Linux Installation problem (?)

Sep 15, 2012 at 6:50 PM

Hi guys, i need your help! i'm trying to install pcsxr on my Ubuntu 12.04 system, and after 1 hour trying to make ./configure work (new system, a lot of thing missed like gtk,glib etc) it finished. Then i type the "make" command, but it stops at some point and says this:


/usr/bin/ld: ../libpcsxcore/libpcsxcore.a(cdriso.o): undefined reference to symbol 'pthread_create@@GLIBC_2.1'
/usr/bin/ld: note: 'pthread_create@@GLIBC_2.1' is defined in DSO /lib/i386-linux-gnu/ so try adding it to the linker command line
/lib/i386-linux-gnu/ could not read symbols: Invalid operation
collect2: ld returned 1 exit status
make[1]: *** [pcsx] Error 1
make[1]: Leaving directory `/home/pgetsos/pcsxr-1.9.92/gui'
make: *** [all-recursive] Error 1


What's wrong? i didn't find anything on google :/

Sep 16, 2012 at 9:25 PM

What architecture are you building it for? If 64-bit, it should be looking for /lib/x86_64-linux-gnu/ If that isn't available, try installing pthreads-dev

Sep 16, 2012 at 9:38 PM
Edited Sep 16, 2012 at 9:39 PM

I'm 99.9% sure it's 32-bit...


in synaptic i searched for pthreads-dev, and except libcr-dev, the other 3 are installed....


edit: also, the file exists....

Sep 17, 2012 at 5:49 PM

Try determining the file type by typing "file /lib/i386-linux-gnu/" and print the result here: From what I can tell, the linker had issues trying to use the library.

You could also try passing -lpthreads as a linker option when configuring. I think you just put LDFLAGS=-lpthreads before the configure command.

Sep 17, 2012 at 9:01 PM
Edited Sep 17, 2012 at 9:01 PM

It gave me this /lib/i386-linux-gnu/ symbolic link to `'


You mean "LDFLAGS=-lpthreads ./configure" ?

Sep 19, 2012 at 12:04 AM

Yes, "LDFLAGS=-lpthread ./configure", not -lpthreads. That was a typo on my part.

Sep 19, 2012 at 1:58 PM

nope, still the same error....

Sep 21, 2012 at 2:52 PM

ok, from the instructions in the documentation it installed properly (i guess...) but it doesn't exist in my dash...