Analog control problems

Dec 24, 2011 at 5:31 PM

Hi,

I'm quite new to PCSXr, so looking for some guidance on getting analog to work correctly. The default plugin recognises my controller including my analog sticks (I'm able to map the movements of the analog sticks in the configuration of the controller plugin so that it shows Axis +1, Axis -1, etc in the rows relating to the analog sticks).  However, when I play Gran Turismo 2, I can't get the analog sticks to work. In that game there is an option screen to configure the analog controls, but I don't seem to be able to access the options - it's like the game doesn't think I've got an analog controller, so has disabled the options.

My system:

Ubuntu 10.04

PCSX 1.9.92 (default plugin)

Logitech rumblepad 2 controller

Any help much appreciated.

Cheers.

Apr 24, 2012 at 6:35 PM
Edited Apr 25, 2012 at 8:29 AM

I'm also experiencing this problem with the latest revision 77577 (Xubuntu 12.04, Sony PS3 Sixaxis Pad).  Defining the controller as "analog pad" in the configuration of the default "Gamepad/Keyboard 1.2.0" plugin has no effect, even after configuring the axis.  All games still boot as if a digital pad is inserted which makes games like Gran Turismo very difficult to play.

dfinput.cfg contains:

 

[PAD1]
DevNum=0
Type=7
Select=65288,0,0
L3=99,0,0
R3=118,0,0
Start=65293,0,0
Up=65362,0,0
Right=65363,0,0
Down=65364,0,0
Left=65361,0,0
L2=101,0,0
R2=114,0,0
L1=113,0,0
R1=119,0,0
Triangle=115,0,0
Circle=120,0,0
Cross=122,0,0
Square=97,0,0
LeftAnalogXP=0,1,1
LeftAnalogXM=0,1,-1
LeftAnalogYP=0,1,2
LeftAnalogYM=0,1,-2
RightAnalogXP=0,1,3
RightAnalogXM=0,1,-3
RightAnalogYP=0,1,4
RightAnalogYM=0,1,-4

 

Where all the other "Digital" buttons are assigned to key presses with the sticks assigned to the axis on the gamepad, although games refuse to acknowledge an analogue pad is inserted.  Glad it's not just me though, I thought I had broken something again lol

Apr 25, 2012 at 3:35 PM
Edited Apr 25, 2012 at 3:36 PM

OK I think I have it sorted, It was using an older version of the plugin from an old PCSX install from the ubuntu repos and so not assigning an "Analog" button at all, after removing it and my .pcsx and .pcsxr config folders the input plugin finally started working properly.  I had to also uncheck multi-threaded for the controllers otherwise it had a spaz attack when it was in analogue mode.

I'm using a sixaxis controller that can be a pain to configure because of the accelerometers (thats why it always gives axis 12 for values) so Ive included my dfinput.cfg config again

 

[CONFIG]
Threaded=0
HideCursor=0

[PAD1]
DevNum=0
Type=7
VisualVibration=0
Select=99,3,0
L3=0,3,1
R3=0,3,2
Analog=98,3,16
Start=118,3,3
Up=65362,3,4
Right=65363,3,5
Down=65364,3,6
Left=65361,3,7
L2=101,3,8
R2=116,3,9
L1=119,3,10
R1=114,3,11
Triangle=100,3,12
Circle=120,3,13
Cross=122,3,14
Square=115,3,15
LeftAnalogXP=0,1,1
LeftAnalogXM=0,1,-1
LeftAnalogYP=0,1,2
LeftAnalogYM=0,1,-2
RightAnalogXP=0,1,3
RightAnalogXM=0,1,-3
RightAnalogYP=0,1,4
RightAnalogYM=0,1,-4

That's with all the controls mapped and the "PS" button as the digital/analog mode switch

Aug 17, 2013 at 7:23 PM
Edited Aug 17, 2013 at 7:24 PM
Hey there, I found this searching on Google because I have the exact same problem, and I can't find the dfinput.cfg file nor edit any file on the plugin.


I'm using a Mac, by the way.

Thanks in advance for any help out there!