Autoreconf error when compiling in Ubuntu 11.04

Jun 26, 2011 at 4:05 AM

Hi!

I have 1 Error:

 

hikaru@hikaru-x01:~$autoreconf -f -i
autoreconf: `configure.ac' or `configure.in' is required

Folow the step for documentation (sorry my bad english)

 

Saludos!

Jun 26, 2011 at 4:12 AM
Edited Aug 13, 2011 at 7:50 AM

Umm you need somes dependencies solve , when you can use the follow command line in a terminal :

 

sudo apt-get install gawk mawk gcc gcc-multilib gcc-4.5 gcc-4.5-base gcc-4.5-locales gcc-4.5-multilib gcc-4.5-plugin-dev intltool intltool-debian gettext gettext-base liblocale-gettext-perl libgettext-ruby1.8 perl perl-base perl-modules libperl5.10 pkg-config libxml2 libxml2-dev libxml2-utils python-libxml2 libglib2.0-0 libglib2.0-bin libglib2.0-data libglib2.0-dev libgtk2.0-0 libgtk2.0-bin libgtk2.0-common python-gtk2 libgtk2.0-dev libglade2-0 libglade2-dev python-glade2 libsdl-sge-dev libsdl-perl libsdl-ruby libsdl-ruby1.8 libsdl-gfx1.2-dev libsdl-ttf2.0-dev libsdl-console-dev libsdl1.2-dev libsdl-image1.2-dev libsdl-mixer1.2-dev libsdl-net1.2-dev libsdl-sound1.2-dev gstreamer0.10-sdl libsdl-ocaml-dev libsdl-pango-dev libguichan-sdl-0.8.1-1 zlib-bin zlib1g zlib1g-dev libxvmc1 libxv-dev libxv1 libxcb-xv0 libxcb-xtest0 subversion libtool nasm libbz2-dev automake autoconf libxxf86vm-dev x11proto-record-dev libxtst-dev libgmp3-dev libcdio-dev libsndfile1-dev

 

With this , you solve much dependencies for Build from Sources ( Emulators , Games , etc ) i hope this help you to compile pcsxr svn from sources without problems :D

Now Try again in a terminal

 

reset && cd $HOME
mkdir svn && cd svn
svn co https://pcsxr.svn.codeplex.com/svn pcsxr && cd pcsxr/pcsxr/
autoreconf -f -i && ./configure --enable-opengl && make && sudo make install && sudo ldconfig && reset
pcsxr



Jun 26, 2011 at 4:15 AM

 

Thank for the inmediatly answer , this work i can compile now!